Staging site SSL error

I am setting up a staging site for my wordpress site - worked through some issues with my hosting provider to get it all set up. I get the login page and enter my user name & PW. That works fine then I get the following error

An error occurred during a connection to Cannot communicate securely with peer: no common encryption algorithm(s). Error code: SSL_ERROR_NO_CYPHER_OVERLAP

My hosting provider suggested Cloudflare check the SSL for their end and issue it if possible so there are no SSL mismatch errors. I’m stuck and not sure where to go.

Cloudflare covers hosts on SSL only immediately beneath the domain. The host name you posted is one level too deep. If you want that covered by Cloudflare you will need to purchase a $10/month dedicated certificate.

Thanks for the quick reply - I asked my hosting provider about options to save $10 a month because we are a startup and $ is tight - they came back with the following - would reissuing the SSL make a difference or is the answer still need to buy the $10 a month option?

I checked the SSL certificate issued by Cloudflare and it is listed with the following two hosts:, * (2 hosts)

The second host is known as a wildcard subdomain and it can be applied to essentially any subdomain on your domain. As such the current SSL should suffice and should cover the subdomain, however since there is a mismatch with the SSL, I suspect that the subdomain has not yet been authorized through the Cloudflare systems. When previewing the site through our server directly and bypassing Cloudflare, the staging site opens up correctly.

I believe that this universal SSL may need to be re-issued by Cloudflare, however since we do not have access to their systems, we cannot do this from our end, unfortunately. As such I would advise you to again contact their support team so they can assist you with this issue further and hopefully, they are able to re-issue the SSL for you.

That is precisely what I said. Cloudflare will cover hosts immediately beneath the domain, so the wildcard will work for but not for

If you want to get this to work on HTTPS and not purchase a dedicated certificate from Cloudflare you will need to unproxy that host and use a regular certificate without Cloudflare.

Thank You - sorry I misunderstood.

This topic was automatically closed after 30 days. New replies are no longer allowed.