SSL www vs promax .me

Hi,

I already have set cloudflare to my website, SSL is working well when browsing:
promax.me

When it comes to www. the following message is showing:
The page isn’t redirecting properly
An error occurred during a connection to www. promax.me

Your feedback is highly appreciated

Camille

If the non-www site is the URL you want to use, I suggest you use the Page Rule as recommended in this tutorial. You won’t need to make any DNS changes since you already have the ‘www’ entry.

2 Likes

@sdayman thank you for your feedback, it worked, however my WordPress dashboard isn’t accessible, this is what i am receiving:
The page isn’t redirecting properly
An error occurred during a connection to promax.me

It’s stuck in an HTTPS redirect loop. Was your site working with HTTPS before you added it to Cloudflare?

@sdayman
WordPress dashboard (managed WordPress with GoDaddy) was working normal
promax.me had an expired SSL with GoDaddy (expired few days ago)
The website was working only without SSL

That’s the problem. You need to get a new certificate on your server. If you can’t get one from GoDaddy, you can probably install a free Origin Certificate from Cloudflare:

@sdayman
When I added the Dummy IP you sent me I had to delete
CNAME | NAME: WWW | CONTENT: PROMAX.ME | TTL: AUTO | PROXIED
The system couldn’t take the Dummy IP without deleting it

Now I paused cloudflare to try another way

If you have problems like I did, try this. It works 100% for me and my sites and is easy to follow. This is a great tutorial, but many others ran into problems and that includes me. I got it to work after some trial and error, it works perfectly fine on all the WP sites I did it on. Here is what I do: Installing a SSL certificate on WP Site: 1.) Go to Cloudflare (make free account if you don’t have one). CF is awesome, and it is free. That’s right, FREE SSL Certificates haha. 2.) Now hit add site, e.g.: yourdomain.com and hit scan 3.) Hit Continue and choose Free plan when asked 4.) Change name servers to the ones it gives you. Go to where you have your domain and change the NS’s. 5.) Once it is done (could take a bit, just refresh often, usually happens within 10 minutes for me), go to Crypto Settings and choose Flexible SSL 6.) Now when that is done and says active with green bar, go here to double check to see if your SSL is active 100%: https://www.ssllabs.com/ssltest/ just type: yourdomain.com and scan it before moving to next steps. If it was successful, it will show Grade A on all the servers it tested meaning your SSL certificate is active and live. YAY! 7.) When that is done, it is time to install the 4 magical plugins you need. Go to Wordpress admin area and install the “Cloudflare” plugin first. Activate it and go to settings all the way down to “Automatic HTTPS Rewrites” and turn it on. Now go back home and hit Apply. First plugin done. Now install and activate “Cloudflare Flexible SSL” (this will help keep an annoying SSL redirect loop from happening, problems which plagues a lot of us learning how to install SSL) so make sure this is the second plugin you install. It’s a pain if you don’t. Now go back to plugins and search for and install: “Really Simple SSL”. Follow the simple directions. At this point your site should show at: https://yourdomain.com and it should have the lock on it. To make ALL pages SSL including WP admin area, search for and install this plugin: “WordPress HTTPS (SSL)”. Once installed you need to go to the left to the tab that says HTTPS and click on it to edit the settings. Tick the first box that says “Force SSL Administration” and click save. That is IT on the wordpress side! You may have to re login to your Admin panel when installing and activating these plugins, that is normal. 8.) Now time to add some page rules in cloud flare for this domain so that when someone goes to www.yourdomain.com or http://www.yourdomain.com it will send them automatically to https://yourdomain.com Go to cloudflare and hit page rules tab. Now hit Create Page Rule. copy this: http://yourdomain.com/* into the section, changing yourdomain with yours, keep everything else the same. Now click Add a Setting under it, and choose “Always use HTTPS” and save and deploy it. Do the whole thing again, this time with: http://www.yourdomain.com/* and save and deploy it as well. Now if anyone visits different URL’s it will always send them to the secure version at https://yourdomain.com Hope this helps someone out there who is frustrated with trying to get this to work! Now that you have an SSL, you’d be wise to read this article on google that shows you how to adjust google analytics for the new SSL change you just made: https://really-simple-ssl.com/knowledge-base/how-to-setup-google-analytics-and-google-search-consolewebmaster-tools/ Enjoy your awesome SSL. :slight_smile:

Hi @camilleattieh,

Sadly, Flexible is definitely not awesome SSL, it is not secure and should be avoided… For your site to actually be secure, you need a certificate on your server and your SSL/TLS mode set to Full (strict). This should not be difficult and can be completely free!

3 Likes