SSL works on iOS but not on PC (Edge, Chrome)

I’m new to this…just finished setting up the SSL certificate on Cloudflare and I have some issues.
The cert is working fine on iPhone but on Chrome & Edge it’s not working at all…
On cloudlflare it shows that everything is working.

What should I do?

1 Like

I didn’t post a screenshot since I didn’t think that a screenshot from edge saying “be careful here” will help you guys…

But, now I’m checking and on my iPhone im getting error 526

On cloudflare - everything is ok: " Great news! Cloudflare is now protecting your site"

You essentially need to make sure you have a valid SSL certificate on your server.

can you elaborate?
i’m using GoDaddy for the hosting
I’ve changed the servers in DNS under my domain on godaddy’s platform.
On couldlfare my “SSL/TLS encryption mode is Full” and working: Great news! Cloudflare is now protecting your site"
once I changed on cloudflare from full (strict) to full i’m back to the older issue which is secure on iPhone (https) but not on Chrome: “Not Secure”
but the certificate is valid !

Thats the proxy certificate. I am talking about your server certificate.

can you please elaborate on what I should do ?
isn’t the server certificate a part of cloudflare?

No, thats part of your server and you need to contact your host about that.

Please, use the search. That topic is being covered several times here every single day. In short, you need a valid certificate on your server, as I already said.

ok, last question
basically you are telling me I need to purchase an ssl certificate from GoDaddy?

Basically yes. I believe your host also offers free certificates, but if they dont and you cant change host, it will be the paid option.

so why do I need cloudflare if I pay GoDaddy? that’s what im trying to avoid…
on it seems that everything is ok

I dont know why you signed up with Cloudflare :wink: but Cloudflare cant substitute an SSL certificate on your own server of course.

Again, that topic is covered up to twenty times a day, please use the search.

1 Like

Sandro, i’d appreciate your help once again.
I did all the ssl certificate setting in cpanel for the server.
Now the secure connection is working on iOS, Edge
on Chrom WordPress on my domain is working on https as well, but my website on chrome is not working on https eventhough everything looks to be ok.

Lets start with the domain, shall we :slight_smile:

@sdayman, do you want to post your favourite link or shall I? :slight_smile:

1 Like

But yes, @yael.schaff, your server certificate is properly in place at this point. Make sure your encryption mode on Cloudflare is “Full strict” now and not just “Full”.

changed. once going to the site it shows the https “lock” icon but then goes to “Not secure”

once again, on ssl checker its working
ios working
Microsoft edge - working…
Chrome - Not working

I guess @sdayman is in the dressing room for Cloudflare TV :wink:

@yael.schaff, your site is generally secure but the issue you experience is described at Mixed Content