SSL working on Chrome but not on IE or Firefox


#1

I have some sites hosted with LiquidWeb as part of a Cloud Sites package.

I installed one of their SSL certificates on one site a few months ago and it works correctly on all browsers. I have to install and try several Wordpress plugins to get all the files secure but it’s OK now.

I’ve been through the same process with another site but it only looks correct in Chrome and Safari. In IE you have to click a prompt to see all content and Firefox just doesn’t see the certificate.

I’ve tried clearing caches and adding a plugin that’s meant to sort this out but the problem persists. Is there a guaranteed way to fix this without trial and error?


#2

Can you post the URL?


#3

#4

You have a mixed content issue, meaning that your sites tries to link to content (scripts/stylesheets/images etc) from a non-https URL.

Try the following (if your hosting provider has HTTPS/SSL enabled):

  • Make sure that SSL is set to Full SSL - and not Flexible SSL.
  • Since you are running WordPress, you may want to check if WordPress Address and Site Address starts with ‘https://’ (Settings -> General)

This knowledge base article may also be helpful:


#5

As already pointed out, there is a mixed content issue. The sharing icons, as well as the CSS and JS files, are being loaded via HTTP.

However it equally does not work in Chrome. So no difference in this regard.


#6

I’ve raised a ticket with Liquidweb since the results for two sites are now inconsistent. They are both Cloud Sites, both on Cloudflare, and both Wordpress sites.