SSL working for only some domains

I have a site (beavoterwi.org) with 2 DNS entries.

CNAME www -> voter-sherpa.netlify.app
CNAME test -> www.google.com

Both have the “orange cloud” (proxied).

If I go to www . beavoterwi . org it tells me that the certificate is invalid (*.netlify.app).
If I go to test . beavoterwi . org it works fine (certificate is the universal cert from cloudflare).

Why is Cloudflare not intercepting ? The universal cert is active, I tried all 3 SSL modes (Strict, flexible, Full).

Should add i have a 3rd DNS entry.
A record -> 192.0.2.1 (nonsense) with a page rule to redirect to www

Orange cloud is on.

curl shows me an invalid certificate (*.netlify.app!!!)

This domain is not active on Cloudflare. It’s nameservers are set to use ns1 nameservers. Until the zone is active on Cloudflare, Cloudflare won’t be able to proxy for the domain.

forgot to delete the question. I bailed on Cloudflare and I’m using Netlify. It was pointed at cloudflare all day but couldn’t get it to work. Now it works great.

just to be clear, i moved nameservers in between the posting of the question and you replying.