SSL working fine on main domain but not on subdomain

I am trying to set up a demo app for a client, where the main domain points to the frontend of the app and a subdomain points to my backend (server). My main domain is working as intended on HTTPS, so I created a first level subdomain with an A record on my DNS; I can navigate to it if i use HTTP but for some reason it just won’t work on HTTPS :frowning:

Do you have Full SSL mode enabled under SSL options?

Moreover, have you re-checked if you have your sub-domain at your origin/host?
Also, if you have an SSL certifiacte at your origin/host, does it cover your sub-domain?
Or you have used Cloudflare Origin CA SSL certificate?

Are the records for the sub-domain :orange: as well?

Thanks for your message friend, i have as of now solved it! However i will answer your questions and state how i got it working: I had Full SSL mode enabled, yes, and the A record for my subdomain was set to :orange:.

I’m deploying a web application using GKE so i had to get a Certificate of Origin Cloudflare from cloudflare and install it on my GKE loadbalancer. After a couple minutes it all worked like a charm!

1 Like