SSL via Cloudflare

Hello, Im trying to activate SSL via Cloudflare.
I enabled strict mode, i put the Cloudflare CA origin certificate on the origin server but when i try to access the site the origin certificate is delivered instead of the SSL from Cloudflare.
Any ideas about how to fix this ?

That would suggest you are not proxying the DNS record (or still have a propagation issue) and connect directly to your server.

Make sure the record is proxied and your local resolver has the current values.

2 Likes

Hi, Thank you for the quick reply

From what i see the ip that it’s trying to access is the cloudflare one :

ping decorix.ro

Pinging decorix.ro [104.21.7.3] with 32 bytes of data:
Reply from 104.21.7.3: bytes=32 time=3ms TTL=59
Reply from 104.21.7.3: bytes=32 time=2ms TTL=59

etRange: 104.16.0.0 - 104.31.255.255
CIDR: 104.16.0.0/12
NetName: CLOUDFLARENET
NetHandle: NET-104-16-0-0-1
Parent: NET104 (NET-104-0-0-0-0)
NetType: Direct Allocation
OriginAS: AS13335
Organization: Cloudflare, Inc. (CLOUD14)
RegDate: 2014-03-28
Updated: 2021-05-26
Comment: All Cloudflare abuse reporting can be done via https://www.cloudflare.com/abuse
Ref: https://rdap.arin.net/registry/ip/104.16.0.0

Your www record is not proxied.

Now it is proxied.

kinda fixed but not really, on incognito it works, on normal chrome still certificate issue. Could be a local chrome problem?

Probably a caching issue at this point.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.