SSL version or Cypher mismatch, I need to reset it, I tried everything`

Hello, I had my website paused in Cloudflare because I was facing a redirect loop error, I don’t know why.
My website domain is and after re-enabling Cloudflare after 10 minutes I got This error, ERR_SSL_VERSION_OR_CIPHER_MISMATCH
you can see a screenshot attached:

I haven’t tried with another browser because I don’t have other browser in my PC but I tried with a website I usually test my websites with: proxysite and he’s getting the same error.
The website was working before adding it to Cloudflare but I need mail redirect so I kinda need to use Cloudflare.

You can reproduce the issue by simply visiting my website

Now, I tried more things to try to fix this error.
I generated a new origin server certificate and paste it into my CloudPanel’s website settings and for now I still have the same error.
I also tried by setting SSL/TLS encryption mode to Flexible and also off, none of them worked.

Sorry for double post, I can’t find edit button on Discourse, enabling Universal SSL while the domain is proxied trough Cloudflare seem to fix the issue. However after enabling that I face another issue, which is too many redirects.

My DNS records are

  • A - domain - IP
  • CNAME - www - domain name
    and the rest are just MX & TXT records for the mail redirection…

Welcome to the Cloudflare Community. :logodrop:

Did you click that link? It leads to the Community Tutorial that will help you fix it.

The most common cause of that message not using Full (strict).


Haha, I missed that link that is made after I type certain words.
I fixed my issue, setting to Full (strict) and also adding Cloudflare certificate to my CloudPanel instance.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.