Ssl version mismatch across site

Getting ERR _SSL_VERSION_OR_CIPHER_MISMATCH on all sites

I’m getting error below while trying to access my website; DNS _PROBE_FINISHED_NXDOMAIN And; ERR _SSL_VERSION_OR_CIPHER_MISMATCH What could be wrong please?

ame . ng
blog . ame . ng
tutorial . ame . ng
academy . ame . ng

Are you using a double-subdomain? For example, something.something.example.com?

Double subdomains are not supported on Cloudflare without Advanced Certificate Manager (which is an add-on).

1 Like

Since the 1st and 4th domain is not proxied, this problem is not related to Cloudflare, also I could not reproduce it by calling the 1st and 4th provided domain.

This error was reproducable and is fixable by creating the DNS entry “tutorial” for the domain ame.ng, so that it exists.

For blog.ame.ng it is as @mcfadyeni said, you are actually redirecting to www.blog.ame.ng which is a sub-subdomain. For second level subdomains you need a special SSL cert, that includes them. For now, I think it is easier to just use blog.ame.ng instead of www.blog.ame.ng.

1 Like

Since the 1st and 4th domain is not proxied, this problem is not related to Cloudflare, also I could not reproduce it by calling the 1st and 4th provided domain.

I have activated Cloudflare for the domain.I read a tutorial that asked me to pause Cloudflare but the issueis still the same

If Cloudflare is paused and it still is occuring it mostly (beside the SSL cert problem for second level subdomains) is not a Cloudflare related problem.

  1. To use Cloudflares features you have to be proxied.
  2. when you get the error DNS _PROBE_FINISHED_NXDOMAIN then the DNS entry for the domain you want to call does not exist - create it.

ame.ng
academy.ame.ng and
store.ame.ng now working
Thanks

But how do i create the DNS for tutorial.ame.ng please

and how do i remove the redirect option for blog.ame.ng please?

Please read the turotial here: https://developers.cloudflare.com/dns/manage-dns-records/how-to/create-dns-records/#create-dns-records which explains on how to create DNS entries.

This must be done at your application, since the redirect is implemented at application level. Probably your baseURL or site address is set to www.blog.ame.ng. Remove the leading www and you shaould be good.

Yes, excatly. You could also use CNAMEs but A entries are ok aswell.

Ah again here at tutorial.ame.ng the same happens, it redirects to www.tutorial.ame.ng with www. Please change that at the application aswell to be tutorial.ame.ng without www.

I have removed the www. from the site url

No you have not. You removed it from the URL you call, but again you get redirected. You need to modify your configuration at your application, so it stops redirecting. I can’t tell if it is in the webserver config or the application, but it happens at your origin.

I still see these headers:

Please wipe all cache, at Cloudflare, at your origin and in your application. And please check your webserver configuration, since it indeed still redirects to the www.

1 Like

I first see a 526 Error, and an immediate redirect to www . Please check your SSL cert as well.