SSL valid but site is not

I have installed the Universal SSL certificate on my origin server, I have also checked multiple SSL checkers and they all say my site is active, however, when my browser does not think the site is secure and turning on Always HTTPS makes my website inaccessible. Also tried to change it to flexible, full and full (strict), but nothing seems to work. Uninstalling the certificate does not help either

The Universal certificate? That one is on the proxies. Did you mean an Origin certificate?

What is your current encryption mode? If it is not “Full strict”, change it to “Full strict”. It should never be “Flexible”.

The current mode is flexible, just changed it to full not strict because I just uninstalled the origin certificate

I meant origin certificate sorry

I have tried it on full strict when the origin certi was installed but it was still the same problem

This image is the error in cpanel when origin was installed ^^

  1. Change to “Full strict”
  2. Configure a fresh Origin certficate on your server

ok will try now

Another issue, your site currently redirects HTTPS requests to HTTP. That is something you need to change in your server configuration.

1 Like

i have identified the issue, it is my site doing the redirect, thank you for your help

That is only partly the issue. You still need the certificate.

yes I installed the certificate like I did last time, it’s on full strict and always https and everything works fine, thanks again

Looks good now.

This topic was automatically closed after 30 days. New replies are no longer allowed.