Ssl unknown issuer error

That’s the correct address, but that’s not the error. You need to post a screenshot of the error.

Not sure which browser that is, but your browser is not using the standard resolver as that hostname should not resolve in the first place. Did you check your hosts file? Check any other network related settings there too (browser-specific DNS, proxies, etc.).

Not in this case. DNS resolution is being done by a local resolver which forwards it to CF. The nslookup results returns CF
proxy addresses

The screenshot is from Firefox. Though, I’ve tried Chrome and Edgium as well with similar SSL error.

At this point this is a local issue I am afraid and not strictly Cloudflare related.

The name itself resolves and loads fine

image

That being said, use the developer tools to check where your browser connects to.

Ok. Will look into it.

Thanks so much for taking time to look into this issue. Do really appreciate the fact that you’re helping without anything in returns.

Cheers.

No worries. IMHO this will be a browser configuration or hosts file issue. You ran an nslookup. What does a ping return?

Pinging [104.21.42.151] with 32 bytes of data:
Reply from 104.21.42.151: bytes=32 time=17ms TTL=55
Reply from 104.21.42.151: bytes=32 time=23ms TTL=55

In that case I’d rule out the hosts file as well and would say it’s browser-only. Maybe try a fresh browser profile and make sure you are not using any browser-specific DNS (e.g. DoH) but only the system resolver and no proxy anywhere either.

Tried Chrome, FF, Edge on different computers…but no cigar :frowning:

Well, you are resolving the right addresses. These addresses won’t respond with an Origin certificate and as evident from the earlier screenshots they actually respond fine. Otherwise I could only point towards someone actively tampering with your connection, though I’d say that should be unlikely.

Agree. BTW, do you work for CF or just part of the community?

Regardless, thanks again (if I haven’t already thanked you :slight_smile:

Try running this command in PowerShell (I believe you are using Windows)

(Invoke-WebRequest -UseBasicParsing -Uri 'https://proxy.[DOMAIN]/cdn-cgi/trace').RawContent

BTW, thanks for chiming in and helping @michael

Loads just fine. Browser issue I am afraid :slight_smile:

Gonna take eyes off of screen for a bit and then retry…It’s all looking blur at this point :slight_smile:

Damm even I am having a similar kind of issue, I have searched all over the internet and even have posted on number of threads on different forum, no solution seems to work. I am really frustrated, can anyone of you here help me resolve this issue, I am very much tired now.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.