SSL / TLS Browser says INVALID certificate

Well I downloaded the certificate from Originserver and am now using it in my Flask Server.
Flask says using https and has no error as far as i can tell.
The certificate is older than 24h but i am not using it that long.
My Browser (chrome, Firefox) says it is an INVALID certificate but shows it is issued by Cloudflare.

Am I missing something? Sorry new to Webdevelopment and Cloudflare.

Cloudflare Origin Certificates are only trusted by Cloudflare. The hostname associated with the Origin certificate must be :orange: on your Cloudflare DNS dashboard.

If the hostname needs to be :grey: then you must obtain a certificate from a regular CA like Let’s Encrypt. Cloudflare is not a CA, and does not provide general purpose certificates for you to install on your own servers.

image
like this right?

oh and new Problem i think?
In Firefox idk if that is cached but i used strg+F5 i can see the website and on chrome i have the ERR_SSL_PROTOCOL_ERROR again.
but on chrome i can reach over the script.domain

I read that thing like 15times in the last 2 days still cant make anything out of it idk from my point of view seems random if it works or not
ALL my DNS settings are :orange: the script.domain is my IP because it changes
and domain.com points to script.domain.com
SSL is from Cloudflare

Cloudflare Origin Certificates are only trusted by Cloudflare. The hostname associated with the Origin certificate must be :orange: on your Cloudflare DNS dashboard.

I have all dns entrys :orange:

That sounds like a local DNS cache problem. From here everything looks fine.

I should rephrase. From here, the certificates look fine. You site returns a 520 error, which is a separate problem.

A 520 error occurs when the connection started on the origin web server, but that the request was not completed. The most common reason why this would occur is that either a program, cron job, or resource is taking up more resources than it should causing the server not to be able to respond to all requests properly.

Review the Quick Fix Ideas in this Community Tip for troubleshooting suggestions.

It is on port 8080 that is the 520 problem i cant solve yet
But i used VPN from Canada and still get ERR_SSL_PROTOCOL_ERROR
ALL 2 entrys are :orange:

Port 8080 is only supported for HTTP on Cloudflare. You probably have “Always Use HTTPS” enabled, so requests to 8080 are being redirected to https://zer0-industries.com/.

% curl --dump-header - --silent "http://zer0-industries.com:8080/" | egrep -i 'HTTP/|Location'
HTTP/1.1 301 Moved Permanently
Location: https://zer0-industries.com/

https://developers.cloudflare.com/fundamentals/get-started/network-ports

OMG totally forgot that one jeeesus
thanks i will try a change of ports

Tryed working with port 8443 bro thanks I crushed my head because of it…
Do you know if i can “hide” the port with SRV entry? Dont get the purpose of it
and kinda want to let people use just https://zer0-industries.com not with port

Not in normal browsers.

Running the Origin on 443 is the normal way to do this. Is there a reason you want to use a non-standard port?

Well i host at home and

  • 8123
  • 80
  • 443
    are set for homeassistant dont know if i can change it to non standard ports there

OK.

The easiest solution is probably to use cloudflared to connect out from the Origin to Cloudflare.

https://developers.cloudflare.com/cloudflare-one/tutorials/single-command

I guess i will try seems like a lot dont really get it already tbh.
Will keep you posted

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.