SSL Successfully installed, no errors on whynopadlock, really simple ssl but https padlock still not visible

ssl
wordpress
https

#1

Hello there!

I encountered a rather strange instance where everything is installed properly and yet the secure padlock is not showing up. It even gives me a NOT SECURE warning on my website.

I installed the Really Simple SSL plugin on wordpress, it shows no errors.
Whynopadlock shows no errors at all.

Can somebody please help me out of this? Would really appreciate!

Warmest Regards,
Ali.


#2

I bet you’re serving mixed content.
Check your page with https://www.webpagetest.org and take a look at the waterfall once the test is completed. You will find some ressorces like java scripts or pictures that are served via HTTP instead of HTTPS.


#3

Hi @MarkMeyer , Thanks for your reply. I checked with the test, it does not show any http content on the website. My website link is www.aquacci.com I spoke with the guys at hostgator, they said the ssl works at their end. Could you see if its working at yours?

Also, there was a self-signed cert in cpanel, I deleted it & cleared cache. However, the website still doesn’t display the padlock.

I get an error: ERR_CERT_AUTHORITY_INVALID

Thanks!
Ali.


#4

Working for me and showing correct Cloudflare-issued SSL cert.

Make sure you’re accessing it via the Cloudflare IP address (ie. haven’t cached old DNS value, and don’t have it set locally).


#5

Same here. Whatever it was, it’s solved.


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.