SSL showing as lets encrypt

I enabled cloudflare on my site and the universal ssl is enabled. Also, force https is enabled. Now the question is why does SSL show as Lets Encrypt… it should be showing as Cloudflare no? I understand Cloudflare at times uses Lets Encrypt but certificate name and issue date is different which gives an indication that the certificate is not working.

Any advice?

You may check if ssl is enabled to full encryption.
Also your dns settings requires to run via cloudflare proxy (the orange cloud symbol).

The cloudflare ssl will be shown usually. It may take some time. In addition you could delete the cache of your browser.

So here’s the setting:

Domain Name in DNS is showing orange cloud
Certificate : Full (Strict)
Tried Incognito mode and different browser still the same.

Also when I checked in https://www.whoishostingthis.com/ it shows dns is cloudflare but the page snapshotn over there shows “This site cant provide a secure connection”.

Universal certificate: Active

Does anyone have any expertise on this please? Need to get it working… Worst case scenario I will move the DNS back to my hosting provider and disable cloudflare… I really want to use this though…

What’s the domain name?

Before moving to Cloudflare did you have working HTTPS?