SSL session resumption

with

gnutls-cli -V -r hostname |grep 'Session ID'

it doesn’t return the same session id when using ssl in full mode, with dns only the session id’s are the same, same goes with ssllabs report, which reports that ids assigned but not accepted.

And the nginx error log is filled with

could not allocate new session in SSL session shared cache "le_nginx_SSL" while SSL handshaking

didn’t find much on this topic, but is there a way to fix session id resumption behind cloudflare?

Ofcourse the ssllabs shows the connection between the client and the cf, but is this something that should be turned off between cf and server or is there any way to make it work?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.