SSL says it's active, site still shows HTTP


#1

Hello, I’ve signed up for a Universal SSL Certificate a few days ago and the Crypto tag says it’s “Active” but my site still shows “not secured”. Even typing in “https” manually still shows it’s not secure. Please help. Thank you!

Site is: cognitivetype.com


#2

Your website doesn’t redirect to HTTPS by default. You can fix this by going to the dashboard -> crypto and turn on both “Automatic HTTPS rewrites” and “Always use HTTPS”.


#3

Okay oh shoot, that broke my site! I turned the button back off but it’s still broken. Please help ASAP?

two things happened, first it seems some of my scripts are not loading, and secondly it still shows up as Not Secured.


#4

Did you also enable Automatic HTTPS rewrites? By the looks of it all of the scripts and stylesheets should be fixable by the option. If not, the issue is a mixed content issue and happens when the browser loads a page on https:// but the webpage references a http:// resource. You can see this by pressing f12 -> clicking console


If enabling that option doesn’t fix the issue, you should try following the below suggestions for fixing it: Community Tip - Fixing mixed content errors


#5

Okay, I enabled that one and it seems the https (when I type it in) no longer breaks my site. phew! you’re being a big help, thank you. I’ll view that article too.

As for the second question, why does the browser still set “not secured” even though it has HTTPS? like so:


#6

Looks like a few of the resources on your page are referenced through javascript or the stylesheet, which Cloudflare is unable to automatically fix. See if any suggestions from “Community Tip - Fixing mixed content errors” fix the issue, otherwise, those files may need to be edited from http:// to // (by you or the website host).


#7

Thanks Judge,
So if I understand correctly, browsers like Chrome will remove the “not secured” warning naturally once the console no longer detects mixed content? (i.e. when i fix the errors?) (i have a wordpress Search & Replace plugin I want to try in a bit here)


#8

Yep. The lock icon will show up once all resources on the website are loaded over a secure connection. And a plugin like search and replace should do the trick :+1:


closed #9

This topic was automatically closed after 30 days. New replies are no longer allowed.