SSL redirects Wordpress Admin to a 404


#1

Wordpress Admin is redirecting to a 404 page after SSL certification and enabled ‘Always Use HTTPS’ option. The front-end of the websites redirects to https and works well.


Cannot Login on Wordpress After installing Cloudflare SSL - Solution
#2

Is your SSL set to Flexible, or Full/Full strict? There might be some origin configuration that prevents admin from loading on HTTPS.


#3

Hi Judge.

I tried it with all three options. The same thing happens. Where should I check re this origin configuration?


#4

Could there be a wp-config setting that’s interfering? There’s this setting:
https://codex.wordpress.org/Administration_Over_SSL

Would you happen to have any Page Rules that apply to wp-admin?

Which page is it redirecting to? You don’t have to post the domain, but the URL path might shed some light on the issue.


#5

It goes to a 404 page. The issue is not with redirecting, once I activate Cloudflare’s Always Use HTTPS option it does the same as define('FORCE_SSL_ADMIN', true); does. But for some reason the admin is not working, it is such as the domain is invalid therefore redirects it to a 404.