SSL Redirection

ssl

#1

I am using an SSL through Bluehost for my domain https://www.bethlehemhaven.org/.

With Cloudflare I have numerous domains that are using the Full SSL feature. Today two of my domains are redirecting to https://www.bethlehemhaven.org/ out of the blue.

Here is one of them: https://www.creativecourtney.com


#2

I’m getting a 301 Redirecting it. Right off the bat I’d say submit a Support Ticket if it used to work and you haven’t changed anything.

In the mean time, did a Page Rule sneak in to redirect? How about something in .htaccess?


#3

Correct, I’m not sure why it is redirecting, and I shot a support ticket to Cloudflare 24 hours ago and haven’t heard back.

Going to http://www.creativecourtney.com/ works correctly but when it is https://www.creativecourtney.com/ is when it redirects to https://www.bethlehemhaven.org

Here is my .htaccess

# BEGIN WordPress
<IfModule mod_rewrite.c>
	RewriteEngine On
	RewriteBase /
	RewriteRule ^/wp-content/endurance-page-cache/ - [L]
	RewriteCond %{REQUEST_METHOD} !POST
	RewriteCond %{QUERY_STRING} !.*=.*
	RewriteCond %{HTTP_COOKIE} !(wordpress_test_cookie|comment_author|wp\-postpass|wordpress_logged_in|wptouch_switch_toggle) [NC]
	RewriteCond %{DOCUMENT_ROOT}/wp-content/endurance-page-cache/$1/_index.html -f
	RewriteRule ^(.*)$ /wp-content/endurance-page-cache/$1/_index.html [L]
</IfModule>
<IfModule mod_expires.c>
	ExpiresActive On
	ExpiresByType image/jpg "access plus 1 year"
	ExpiresByType image/jpeg "access plus 1 year"
	ExpiresByType image/gif "access plus 1 year"
	ExpiresByType image/png "access plus 1 year"
	ExpiresByType text/css "access plus 1 month"
	ExpiresByType application/pdf "access plus 1 month"
	ExpiresByType text/javascript "access plus 1 month"
	ExpiresByType image/x-icon "access plus 1 year"
	ExpiresDefault "access plus 1 weeks"
</IfModule>
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

#4

On the surface, it sure looks like a glitch that Support would have to help out with. If you post the Ticket # here, sometimes the mods check in on the weekend and might be able to look it up.

If it’s not .htaccess, then check your Cloudflare Page Rules section if something snuck in (not likely).