SSL redirection issue


#1

Hello,

I have turned on SSL for my site as well as downloaded the Flexible SSL plugin and activated it. I have added a page rule http://*mydomain.com to always use HTTPS.

However, when I go to my site, the only page that redirects to HTTPS is the homepage. When I go on my site and go to other pages, they are the not secure version.

how can I redirect all pages to HTTPS?


#2

The Page Rule would need to have a wildcard on the end as well.

HOWEVER :smile: you don’t need to do it via Page Rule anymore. There is now an optional setting on the Crypto page that will force HTTPS for all pages.


#3

does this setting in crypto properly redirect all pages, so if there is a drop in rankings, they should bounce back?

thanks


#4

I don’t know how the redirects should impact rankings, but this Always Use HTTPS setting is essentially a page rule that you can turn on without burning one of your page rules. Whatever the behavior is if managed via page rule should be the same.


#5

is this a 301 redirect?


#6

Yes, Always Use HTTPS gives a 301 to the same path, but with https