SSL problem with Safari Browser when loading website

Hi there, I’m getting this message “Safari can identify the identity of the website” The certificate of this website is invalid… the URL of the website is https://www.softforpc.com, I have tested on many devices using safari and same on all of them.

Also, I tried to search on google the website domain on Google and it’s not appearing when searching from Safari. Does someone know why this happens and how can be solved?

That’s…weird. It comes through fine for Safari on my Mac (Catalina, latest versions of OS and Safari).

Can you dig a little deeper to see more information on the certificate, like which domain the certificate thinks it’s for?

This is what appears when I load the site.

That looks pretty retro. Which version of Safari and MacOS?

This is my Mac OS Version. So all Mac users with old version of Mac and Safari will get this message it is strange. Is this from Cloudflare or not?

This topic was automatically closed after 30 days. New replies are no longer allowed.