SSL Path Issue

dash-dns
dash-crypto
#1

Hi guys,

I am new with Cloudflare and I have a question about the implementation.
I would like to implement cloudflare for my web application but I have an issue.

I have SSL from bluehost and also I have a websocket server which runs in background. For websocket server I need the relative paths for ssl cert.

My questions is:
Now, I am not using Cloudflare and the relative path for cert is: /home/domain/certs/ and /home/domain/keys. I tried few months ago to move on Cloudflare and I got errors from websocket server : Err_cert or something like this, then I changed the DNS back to bluehost. What path should I use after I will move to Cloudflare? Can anybody help me with this issue ?

Thank you!

#2

By relative path I assume you need to load the certificate and the key into memory, right? That would be unrelated to Cloudflare as Cloudflare is only a proxy in front of your server.

What is the exact URL we are talking about and can you post screenshots of the error?

#3

In this moment I am not using Cloudflare. But I will change the DNS in order to get the error and I will come back with the error.
From what I remember when I moved to cloudflare:
I changed the DNS, after few hours the websocket server was not working. Let me few hours.

This is the code where I add the relative paths:

#4

This configuration would be entirely unrelated to Cloudflare. The only place where Cloudflare could be involved is if you connect to your websocket server via Cloudflare and there is some other SSL issue but for that we would need the URL and the screenshot of the error.

#5

Ok, I will change the DNS, and I will come back. Thank you!

#6

I have just changed the DNS, this is the error:

#7

This is aformentioned issue and not related to your certificate.

You are trying to connect to a port which is not supported for HTTPS by Cloudflare.

#8

Yes, you are right. I have just changed the port and it works now.
But, there is a problem with TTFB. Now is double as time to what it was. I have 980ms, before move to cloudflare was 500ms. Is it a configuration issue?

Thank you!

#9

It might be but it could also simple network latency. Keep in mind this connection cannot be cached, so if you are routed via a server which is farther away it might also come with an increase.

closed #10

This topic was automatically closed after 31 days. New replies are no longer allowed.