SSL Origin Certificate installed on Addon Domain gives an Error

Hello, Please I need expert help with this. I’ve been trying for hours to install cloudflare free SSL certificate on my Addon domain at https://dojnaturals.com but it keeps throwing privacy errors on my browsers; Chrome and firefox.

I then tried to install the the origin ssl certificate on the server using the steps I found here https://developers.cloudflare.com/ssl/origin-configuration/origin-ca but the errors persisted.

What I have done.

  1. I have used page rules to force https on dojnaturals
  2. All the proxies are checked and are on orange cloud
  3. SSL/TLS encryption mode is set to Full (strict)
  4. Revoked the first origin SSL certificate and redone the process all over

Still same insecure connection. I’m kind of frustrated at this point. does this mean I can’t use cloudflare on my Addon domain?

Please help!

I’m not seeing a privacy error in Firefox.

I sure hope you put the origin cert back on the server.

Thanks for replying.

Yes the origin cert is back on the server but for some reasons, I’m still getting the error on my end.

I even tried with my mobile phone on Safari and chrome, still same error.


I’m unable to replicate that. All the site checkers I’ve looked are connecting to the site.

1 Like

oh I just Checked. It has been resolved.

Thank you for your time.

1 Like

Well I’m sorry to reopen this issue but the SSL is not stable.
After a while it says unsecure again. I don’t know why it can’t maintain a secure connection.

Any help to fix this will be greatly appreciated.
thanks

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.