SSL only working when https is used


#1

I have set up the automatic redirect to https ( Always use HTTPS Redirect all requests with scheme “http” to “https”), but when the address does not include https:// the certificate does not work. Any suggestions?


#2

Well, without specifying https:// it won’t work, obviously. The main issue here is that it should redirect.

Could it be possible that it’s redirecting, but showing mixed content errors?

Ideally it could be helpful if you shared the domain here, otherwise you could try https://www.whynopadlock.com/.


#3

Thanks for your help. I tried the page that tests padlock that you gave me and the only two negatives are:


and

I guess I should now add that code to the htaccess file. But why isn’t the server forcing the https is a mystery to me when I have setup a redirect inside CPanel from domain.com to https://domain.com
Then I set here in Cloudflare to redirect to Https automatically.


#4

OK Added the code to force the server to redirect to https. Working now!. But this is the first time it happens to me that I have to add code to htaccess to force the server to go to https. Could it be that the Cloudflare SSL service does not redirect automatically with certain servers?


#5

Cloudflare, provided that the specific subdomain is :orange:, redirects whatever server is behind himself when you turn on the option to do so.

I can’t find any reason why that wouldn’t happen given the previous conditions…