SSL only securing with www and not without, also on wordpress


#1

I have two websites I am working on making SSL positive and moving over to HTTPS.

My website for elev8blacktown.info when I enter it like this:
https://elev8blacktown.info/ (not entirely secure)
https://www.elev8blacktown.info/ (Secure)

My website hauntedhouseblacktown.info when entered like this:
https://hauntedhouseblacktown.info/ (not entirely secure)
https://www.hauntedhouseblacktown.info/ (not entirely secure)

Both of them use wordpress and are hosted on Amazon AWS platform. The websites are running as an instance and have a dedicated ip address and using route 53 to setup ns and a records.
I am using A records only at the moment to point my website to my domain.
Like below

A Record, value IP, www
A Record, Value IP, non WWW

Hopefully someone can help and would be really appreciated.

Regards
Chris


#2

:wave: @chrisditfort,

Your site is serving a non-secure asset on the page. https://developer.mozilla.org/en-US/docs/Web/Security/Mixed_content/How_to_fix_website_with_mixed_content

On https://elev8blacktown.info/ it appears to be the logo according to Chrome’s developer tools.


You can try enabling " Automatic HTTPS Rewrites" on the Crypto tab and see if that fixes it. Otherwise you may wan to update the source/settings for the log.

-OG


#3

Thank you. Very helpful it got me thinking. My logo was using http:// so I adjust it to HTTPS and it fixed it.

Regards
Chris