SSL on WWW. and non www


#1

Hi there, I believe I have everything set up correctly, but clearly I don’t so I am coming here for some support.
When I go to www.sprucetreemedia.ca everything is fine and dandy. When I go to sprucetreemedia.ca I get an insecure error and can’t proceed to the site. I have the certificate setup to be for sprucetreemedia.ca and *.sprucetreemedia.ca so I am not sure what the issue is. Would love some insight into this.


#2

You need to fix up your DNS here:
Make sure your www entry looks just like the main entry for sprucetreemedia.ca. My fingers are crossed that this works, as your setup looks to be a CNAME workaround.
Then make sure that www entry is set to :orange:

If the ‘www’ version is what you want everybody to use, this final step should make everything perfect:
Go to Cloudflare’s Page Rules and create a rule: Match sprucetreemedia.ca* and Add Setting for Forwarding URL (301) to htps://www.sprucetreemedia.ca/$1

This will forward all the non-www requests to your secure www site.


#3

I set up cloudflare through my hosting provider, so it automatically set it all up for me.


#4

Contact their support people. They should be able to get you going.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.