SSL on subdomain (Free cert)

I just added Cloudflare this morning to a domain of mine and the domain itself is SSL ready but a subdomain shop.* doesn’t seem to be valid. It is the only subdomain I have routed through Cloudflares HTTP for SSL, just my shop. and my main domain are orange cloud. Do I just need to wait and let the SSL propagate maybe? I did “deactivate” one subdomain (www) in order to prioritize only “shop.”. It is a free cert. Any tips? Need my subdomain on SSL soon and it’s a bummer that it worked for main domain but not sub.


Would like to confirm, is this a single subdomain? Eg. say your domain is, this is Confirming since the free certificate is not valid for two-level-deep subdomains like or Also if possible share the error message you get.

1 Like

That does appear to show a valid cert. The error in your first screenshot is a mixed content error.


Lmao okay I refreshed again now it works man I feel dumb - my bad for the spam of replies guys. THANK YOU!

No problem! Glad it is sorted now.

This topic was automatically closed after 30 days. New replies are no longer allowed.