SSL not working!

ssl
dns
wordpress

#1

So we have recently added an SSL certificate on our server but it’s not working. Also, our redirects are not working as the following error is displayed:

“This site cannot provide a secure connection” but in the URL bar https://www.domain.com appears where https:// is in grey color. This is only for the redirects. However, our website is loading without the https displaying in the URL.

I have talked to my hosting company and they say that CloudFlare needs to activate their SSL certificates in order for our hosting company’s SSL certificate to work.

Since we have gone live with our new website there are a lot of expectations to meet. Would really appreciate it if someone can help me out.

Thanks


#2

It sounds like your certificate has not been issued. What’s the Status for your Certificate in your Cloudflare Crypto settings page? It should be something like “Active Certificate.”


#3

Hi sdayman

Not sure which setting you are talking about but I have uploaded a screenshot of my crypto settings page. Hope this helps.

Thanks!


#4

It looks like you’ve “Disabled” Universal SSL. You don’t have an Edge Certificate (that’s one you’d pay for), and you don’t have a Universal certificate (see picture at bottom).

Scroll to the bottom of that screen and click Enable Universal SSL. That should re-issue the Universal SSL certificate and give you an Active status:


#5

Thanks for the reply.

Do I have to buy an Edge certificate for everything to work smoothly? As, I was told by my hosting provider that any free certificates that CloudFlare provides will work because at the moment we have an active certificate on our server.

I have enabled the universal certificates as advised.

However, I don’t understand why I have to pay for an Edge certificate?

Hope to hear soon.

Thanks


#6

You don’t need to pay for an Edge certificate. But you need to have some sort of certificate. You disabled Universal, and didn’t have Edge. Hopefully now you have an Active certificate.

The good news is you have a working certificate. Now you just need to work on the Mixed Content issue that’s preventing you from showing a :lock:. You have five images using HTTP URLs.

It would help if you enabled the following on your Cloudflare Crypto page: Always Use HTTPS, and Automatic HTTPS Rewrites. That should complete your SSL setup.


#7

Thanks a lot.

I have done the changes as suggested however, still unable to see the secure padlock on our website. The secure padlock does flicker while the website loads at first but its gone when the page is loaded and the following appears:

image

Thanks


#8

Yeah, same Mixed Content. You’re going to have to dig a little deeper.

First, make sure your WordPress General Settings have your website’s URL set for HTTPS.
If you can’t set it there, you’ll have to do it in wp-config:
https://codex.wordpress.org/Changing_The_Site_URL

If you have access to your .htaccess file, add this header:
Header always set Content-Security-Policy “upgrade-insecure-requests;”


#9

Everything works great for now :slight_smile:

Thank you so much.

Can you suggest how I can effectively use my page rules? As I have observed the about us page takes a lot of time to load. But I am happy with the speed of the services and the homepage.

Thanks


#10

Upon first load of the About page, the longest wait is for the page source itself.

I strongly recommend you get a Caching plugin like W3 Total Cache (I use WP Fastest Cache). It will pre-generate your page for visitors.