SSL not working |

I changed my nameservers on Godaddy. I installed “Flexible SSL for CloudFlare” plugin for my WordPress website. Enabled “Always Use HTTPS” in Cloudflare.
I followed all the steps. Https is still not showing up for my website.
I get the following error:

This site can’t provide a secure connection

xyz sent an invalid response.
ERR_SSL_PROTOCOL_ERROR
Please help.

What is the domain name?

Was your WordPress install on HTTP Website before switching to CloudFlare?

Have you changed the www and domain A records to orange?
Also selected under SSL option to “Flexible SSL”?

If still not working then put

define( 'FORCE_SSL_ADMIN' , false); 

to wp-config.php and try open your website in “anonymous” or “new private browser” - could be due to the browser cache to get the error you have.

If success, change in options the “blog url” and “home url” to https://yourwebsite.com.

Then change “FORCE_SSL_ADMIN” from false to true and try if that works too.

Install Really Simple SSL plugin.

Install Better Search Replace plugin and use it to check and replace http to https links in your database due to possibility of the “mixed content error”.

If not, then if possible login to phpMyAdmin, change blog url and home url value to https yourwebsite .com

If not working, PM me with the details and login of CloudFlare and WordPress admin, I can fix it for you as soon as possible and also will write back here the steps that were needed to be done for anyone else having the same issue.

Thanks

I selected “Full” instead of “Flexible” under SSL options. I changed it and got HTTPS immediately!!! I can’t thank you enough!!!

1 Like

I am using Free Cloud Flare SSL for my two sites. Is it better to use Really simple SSL or should i used cloud flare free ssl instead.is it impacts on website?
Reference:cricfacts , coffeemarto (https://coffeemarto.com/)

Glad it works :slight_smile:

You are free to mark this topic as solved.

Good question.

I have read some topics where people have had issues with their hosting cPanel SSL and CloudFlare SSL.
Especially when went on “Full SSL”, while “Flexible SSL” did not worked well…
Moreover, even in combination with Really Simple SSL.
But, as far as I haven’t got any, I cannot comment on that.

Personally, I prefer using Really Simple SSL with CloudFlare “Always use HTTPS” and “Automatic HTTPS redirection”.

But there were cases like favicon which has had mixed resource, and then I would get “this site is not secured”.

Moreover, later when you have some news portal with 50k articles in WordPress, even with Yoast SEO, switching from HTTP to HTTPS is “pain in the ■■■”.
So, when finished with all the configuration, I would just use Better Search Replace plugin to replace HTTP links to HTTPS in my database, including posts, Yoast SEO links, metadata, terms, attachments, etc.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.