SSL not working without www in URL

Hello :slight_smile:

We are having a trouble with configuring our domain. We use external e-commerce platform called VENDERO. The only way to configure Cloudflare SSL with our domain in the VENDERO panel is adding CNAME records to our domain (in our domain provider panel). As I found in Cloudflare documentation, the SSL setup with CNAME has some limitations - “1. Only subdomains, not the root domain, can use Cloudflare’s services. This limitation is imposed by Internet DNS specifications.”: Understanding a CNAME Setup – Cloudflare Help Center

This issue occurs here: https://trenuj.pl/ - when we had the same A records in DNS zone for trenuj.pl and www.trenuj.pl we had the SSL error (as it is right now). When we changed it to redirect the domain to address https://www.trenuj.pl we had a server error.

Here everything works fine: https://www.trenuj.pl/ - and also if you visit trenuj.pl, you will be redirected to www.trenuj.pl with secure connection.

And here comes our problem - we don’t have access to our ftp server as the VENDERO is not allowing you to have access to the system files, so we are unable to redirect website traffic directly to address with www. What can we do to fix it?

As you’ve identified - you are using the CNAME setup via a Hosting Partner - meaning Cloudflare does not provide your authoritative DNS for the domain and Cloudflare cannot power the apex domain e.g. trenuj.pl or provide SSL coverage for it.

To have SSL working on trenuj.pl you would need to either:

a) Have your hosting provider enable SSL on your origin server and provision a certificate & configuration (have them also redirect to https://www so all visitors ultimately go via Cloudflare)
b) Move to Cloudflare directly via a “FULL” setup which is where you switch your DNS to us - then we can protect & provide SSL for your apex domain. To do this you would just open a new account at Cloudflare, add the domain and follow the onscreen instructions to switch your NS.

1 Like