SSL not working when being proxied by Cloudflare

I recently installed an SSL certificate from ZeroSSL in my new .dev website. When I have Cloudflare set to “DNS Only” the site loads as it should (secured), but when I set it to Proxied I get the 522 Error. I have the domain set to “Always Use HTTPS” in the SSL/TLS Edge Certificates page and I can’t see any other settings that might be causing the issue.

It should be noted that I have other Cloudflare (proxied) accounts for different (unsecured) domains, running on the same Digital Ocean Droplet, and they work as expected, so I don’t believe this is a Whitelist IP issue as I’ve found suggested in my searches.

In the SSL/TLS encryption settings, what is your mode set to? If it is Off or Flexible, switch to Full, then try again.

1 Like

@thedaveCA you nailed it! Thank you so much, I never would have thought this to be the cause of my issue.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.