SSL not working, SSL set to active

ssl

#1

Hi community!

I use Cloudflare regularly at work (I’m a developer), and I’ve just signed up for my own personal account.

https://www.cloudest.co.uk doesn’t work, I can load with http. I have selected the ‘Flexible’ option for SSL under the crypto tab. I did previously have a Let’s Encrypt SSL certificate on this domain. Is that where my issues are coming from? Even in a browser I have never used, the HTTPS isn’t working.

Thanks
Chris


#2

Is there an error? Currently it seems like it’s set to “off” and the https version of the site is redirecting me to the http version of the site.
https://www.ssllabs.com/ssltest/analyze.html?d=www.cloudest.co.uk&hideResults=on&latest
Seems like SSL itself is working now… maybe it fixed itself? I’ve heard it takes a little while to set up.


#3

Right now you have a redirect loop. From http to https and back to http etc. Do you have some redirection setup on the origin server? I suggest to remove it and let Cloudflare deal with redirection by toggling the “Always use HTTPS” option to on.


#5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.