SSL not working on subdomain

#1

(I’m a new user here and can only post one image and link. Here’s my question all inside one image)

0 Likes

#2

Cloudflare’s certs have two entries: example.com and *.example.com
You’re covered at this end. The *.example.com covers www and lab.

Your ‘lab’ subdomain is throwing a 521 error, meaning it’s not responding to Cloudflare’s requests. This can be if Cloudflare SSL is set to Full and your server doesn’t support SSL.

0 Likes

#3

Thanks for the help @sdayman. I’m still having trouble.

I checked and Port 443 is open:

I tried setting my SSL to “Flexible” and my site main site went offline.

I don’t have an .htaccess file to check as it’s not part of Discourse.

Can you help me identify if the problem is a Discourse, Cloudflare, LetsEncrypt or host (Digital Ocean) problem?

0 Likes

#4

When all else fails, set that subdomain to :grey: and see if it works: http or https. Since it sounds like you’re using Full SSL (yay!), that subdomain should be accessible over HTTPS when set to :grey:.

0 Likes

#5

I was able to resolve it. Issue was how I installed Discourse (1-click, instead of 30-min guide). When I asked the Discourse team, they shared that Cloudflare causes issues and recommended I bypass and use Cloudflare for DNS only.

Thanks for the help!

0 Likes

closed #6

This topic was automatically closed after 30 days. New replies are no longer allowed.

0 Likes