SSL not working on subdomain, And subdomain is working without SSL

subdomain

#1

Hello.
I have a website that working well on SSL, I created a new subdomain, But it is not working on SSL, But when i remove the SSL from subdomain, It is working (from Wordpress settings)
I added the A record for subdomain.
My domain kparadise.org
subdomain ar.kparadise.org

Is there any steps i have to do?
Thanks!


#2

What do you mean by ‘if I remove SSL’?

your subdomain is redirecting to www.ar… but www. is mit covered by Universal SSL. Only the second (domain.com) and 3rd level (such as www., or ar in your case) are supported.

www.ar. has no DNS record by the way.


#4

Hello,
In Wordpress, there are options: siteurl, home, you have to put the URL of your website, When i put them: http://ar.kparadise.org it is working, When i put them https://ar.kparadise.org it is not working and open https://www.ar.kparadise.org.
I don’t know why.


#5

Possibly some cached DNS entries on your end. (assuming you did some changes recently).

According tho the follwing, http://ar.kparadise.org redirects to https://ar.kparadise.org which redirects to https://www.ar.kparadise.org. Watch the bold text.

Connected to ar.kparadise.org (104.24.124.251) port 80 (#0)
GET / HTTP/1.1
User-Agent: curl/7.35.0
Host: ar.kparadise.org
Accept: /

HTTP/1.1 301 Moved Permanently
Date: Tue, 22 Jan 2019 20:36:39 GMT
Transfer-Encoding: chunked
Connection: keep-alive
Cache-Control: max-age=3600
Expires: Tue, 22 Jan 2019 21:36:39 GMT
Location: https://ar.kparadise.org/
Server cloudflare is not blacklisted
Server: cloudflare
CF-RAY: 49d4d063364c6493-FRA

SSL conntect:

SSL certificate verify ok.
GET / HTTP/1.1
User-Agent: curl/7.35.0
Host: ar.kparadise.org
Accept: /

HTTP/1.1 301 Moved Permanently
Date: Tue, 22 Jan 2019 20:37:34 GMT
Content-Type: text/html; charset=iso-8859-1
Transfer-Encoding: chunked
Connection: keep-alive
Set-Cookie: __cfduid=de68f024cb7e008d8122dc760161a38bc1548189454; expires=Wed, 22-Jan-20 20:37:34 GMT; path=/; domain=.kparadise.org; HttpOnly; Secure
Location: https://www.ar.kparadise.org/
Cache-Control: max-age=600
Expires: Tue, 22 Jan 2019 20:47:34 GMT
Expect-CT: max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-c gi/beacon/expect-ct”
Server cloudflare is not blacklisted
Server: cloudflare
CF-RAY: 49d4d1bbcc4cbed0-FRA

https://www.ar.kparadise.org has no DNS record:

nslookup www.ar.kparadise.org
Server:         172.30.0.150
Address:        172.30.0.150#53

** server can't find www.ar.kparadise.org: NXDOMAIN

That’s why it fails.

Would you mind to post your DNS settings and Page Rules (if any)? You can blur out the IP addresses from your DNS settings if you like.


#6

Hello
The http://ar.kparadise.org open http://ar.kparadise.org not https://ar.kparadise.org

And the https://ar.kparadise.org open https://www.ar.kparadise.org

I want that: the url https://ar.kparadise.org open https://ar.kparadise.org not https://www.ar.kparadise.org

That what’s happen with me.


#7

This is page rules and dns settings


closed #8

This topic was automatically closed after 30 days. New replies are no longer allowed.