SSL not working on port 8880

I’ve configured an A record like this (IP is just an example):

A	subdomain	Proxied

I also have an endpoint running on port 8880, which is supposedly a Cloudflare supported. So now I want to access my endpoint like
but it’s giving me an ERR_SSL_PROTOCOL_ERROR. I also tried with one of the HTTPS ports since it’s not clear to me whether being HTTP or HTTPS refers to the connection from Cloudflare to my server or from the end user to Cloudflare, but got the exact same problem.

I can’t use ports 80 or the HTTPS one because they’re being used by another service. Is there any way I can use Cloudflare to put my endpoint behind a domain + SSL? I don’t mind having to put the port next to the URL as a end user since this is for an API.

Just to be clear, I’m not trying to redirect the subdomain to a specific port. That’d be ideal but apparently is not possible in any reasonable way. What I’m trying to do is just to be able to access my service at 8880 by including the domain and port on my web requests.

8880 is supported, but only for HTTP.

A list of ports enabled for HTTPS is at Network ports · Cloudflare Fundamentals docs


You can unproxy, then you can use TLS on that port as well.

Thanks Sandro, I tried to link to that document but couldn’t because I’m new here, it still isn’t clear to me whether they mean HTTP(S) on the Cloudflare-MySite connection or EndUser-Cloudflare connection. What I’m trying to do is have Cloudflare take care of the TSL certificate while I expose my endpoint over HTTP to Cloudflare. I tried using port 2083 (which is listed as HTTPS port) and exposed my service over HTTP on that port. But when when I visited mydomain:2083, I got a Cloudflare error saying the certificate on the endpoint wasn’t valid. There’s no certificate on the endpoint, so it looks like Cloudflare is expecting the endpoint itself to be HTTPS. I also tried 8880 but this time I’m getting a Chrome ERR_SSL_PROTOCOL_ERROR.

You can’t do that in the first place, as that will still keep your site insecure. If you need SSL, you need a certificate on your server.

But as mentioned, the port does not support TLS. You either unproxy or use a different port.

1 Like

Bottom line, make sure your site loads fine without Cloudflare, then it will also work when proxied, but you do need to use an HTTPS port of course.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.