SSL not working in Sub domain

Hello community,
SSL in my sub domain is not working while its working properly in main domain
Please guide how to setup the same in subdomain.

What;s the subdomain ?

my main domain is
ansitindia.com and sub domains are track.ansitindia.com and trakzee.ansitindia.com

Hi @developer22 ,

Thanks for sharing the domain

First of all Your domain is not using Cloudflare Nameservers , did you added your website to Cloudflare

Your domain is using Nameservers
ns09.domaincontrol.com.
ns10.domaincontrol.com.

Cloudflare Diagnostic Result

No We are using Cloudflare domain, Mr.Neeraj

Then how can we help you ?This is Cloudflare Community

No I mean to say that, we are using Cloudflare domain Mr.Neeraj

This subdomain is unproxied and offersa wrong SSL Cert for this domain:

So if things are not proxied they are not related to Cloudflare.

And like @Neeraj_1 said: your whole domain is NOT using Cloudflares NS, see: DNS Checker - DNS Check Propagation Tool

3 Likes

My name server is now at Cloudflare
Screenshot_1

Till now some regions still report old NS, wait untill it is 100% propagated, then we can proceed.

In the meantime please provide your:

  • SSL settings
  • proxy status (for all 3 mentioned domains)
3 Likes

Hi @M4rt1n Where can I find the proxy setting

Hi @developer22 ,

Now your site ansitindia.com is using Cloudflare Nameservers

alan.ns.cloudflare.com.
sandy.ns.cloudflare.com.

The Records are 100 % propagated Successfully so we can now continue further !

Shown in the Image as Cloudflare Proxy Toggle

Mixed Content

Your website has mixed content which means mix of secure and non-secure resources found on a webpage .

Error Found

Here’s information about it

https://support.cloudflare.com/hc/en-us/articles/200170476-Troubleshooting-mixed-content-errors

1 Like

I just checked it, all 3 of your mentioned domains are proxied. That’s good.

About the SSL setting I can just recommend using “Full (Strict)” with a valid SSL cert, or even the Cloudflare origin SSL cert. This is free and up to 15y valid.

Please also turn on other SSL features like “Always use SSL/HTTPS” and make sure you set your BaseURL on your application according to your new setup to HTTPS, so all links in the DOM and elsewhere are adjusted to HTTPS.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.