SSL not working in my site with Cloudflare

Hi there,

I have read all over the internet but I do not seem to find the way to fix SSL in my site.

On Let’s Encrypt SSL I get this error and I am stuck:

  • Could not reach challenge directory over URL/.well-known/acme-challenge/really-simple-ssl-permissions-check.txt. Error code 404.

Where URL is the site but this forum does not allow to include a link.

After contacting with hosting provider and doing some tests, it seems to come from Cloudflare the problem.

Do you have any idea how to solve it?

Thanks :smiley:

Also trying to fix the error than Let’s Encrypt SSL gives me I get this error:

Total record size limit exceeded. (Code: 83011)

How is it possible that you add a TXT record and it tells you it is too long when I have it in other sites?

Wow … I read many other people could not fix it and no answer from anyone …

Hello there,
Thanks for the post.

If you face LE-SSL issue, why won’t you contact the issuer?

Again, this seems to be confusing. Are you using Cloudflare? Is that the SSL you’ve uploaded?

Basically, I do not have SSL in my site.

When you set up the site with Cloudflare, I guess it all should be done automatically.

I am not a tech expert, but normally, I install that plugin on Wordpress and does it all automatically without hassle.

If you are using Wordpress, you can use Cloudflare protection via plugin. Else, you can set it up from the Cloudflare dashboard as well.

Let’s Encrypt has a helpful community that can assist you with challenges using their platform.

The Cloudflare Origin CA is another option.

Let’s Encrypt is just a plugin.

But if I make a website, I follow the steps on Cloudflare and I change DNS as described, how is it possible that now my site has no SSL?

Cloudflare provides SSL with the free plan, right?

It’s bit confusing here which SSL actually you would like to use. If you are using Cloudflare, after the initial set up and the propagation, you are good to go. SSL is set up.

Universal SSL comes by default :smile:

It is important understand that Cloudflare Universal SSL applies to communication between Cloudflare and your visitors. You still need to secure the traffic between Cloudflare and your origin server. This is where Cloudflare Origin certificates can be used if you don’t already have valid certificates in place.

That error comes from your origin host/server.

Are you using Apache or Nginx?

Furthermore, have you tried using the webroot method? :thinking: (just make sure to unproxy :grey: the DNS records before reissuing/renewing the LE SSL certificate, upon success proxy :orange: them).

1 Like

[quote=“cryptoruay, [post]):1, topic:413160”]
o so
[/quote]
Hi i am facing the ssl handshake error on my website testdepurete.info. Can you help me in this ? I have tried contacting my hosting company that is hostinger.

I checked and your website loads fine at my end via HTTPS and using Cloudflare nameservers:

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

My isuee is Cloudflare.

When I run the website without Cloudflare proxy and just DNS it all works well and SSL loads from my hosting.

When I use Cloudflare, Cloudflare is failing providing a valid SSL certificate.

After comparing my other sites I see this fails:

It is pending while in other websites it is active. Of course my site fails while using Cloudflare for this reason maybe.

I remove proxy on Cloudflare and it works perfectly which means that the problem is Cloudflare.

Thanks for the replies and the help guys !!

solved. it was that. i found a way to reissue it and now it works. it was 100% a problem from Cloudflare. thanks for the help.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.