SSL Not Working - Host says need RSA key?


#1

Hello,

My Cloudflare account says I have my SSL certificate active on my website: http://mseethal.com. But https://mseethal.com returns an error page. According to my web host, I have to provide them with an RSA key for them to “Instal” my certificate for me (for a fee of course.) How can I find this “RSA” key if I need to provide it for them, and how can I get my SSL Certificate working? (I submitted this question as a ticket as well under:1434132)

Best
Michael


SSL - Delays Authorizing Certificate
#2

Do you have Cloudflare’s SSL set to Full or Strict? I’m guessing HostGator doesn’t have their own SSL certificate installed on your site, so it’s causing that error.

You don’t need to provide them an RSA key. You just need to find a way for HostGator to enable standard SSL for your site. Or set Cloudflare’s SSL to Flexible.


#3

So I switched my SSL to flexible. I now have that beloved “s” on my website, but it’s now way out of wack. What should I do to fix this?

I think there is some code or something I have to toss into a file, but I’m not sure what code and what file. This assumption may also be wrong.


#4

Go to WordPress Settings -> General and make sure your domain is set to https://mseethal.com


#5

Or you can set this in wp-config.php:

define(‘WP_HOME’,‘https://mseethal.com’);
define(‘WP_SITEURL’,‘https://mseethal.com’);


#6

So when i put those code lines into my file I get the following message:
Parse error: syntax error, unexpected ‘:’ …/wp-config.php on line…

And I also cannot log into my wp admin dashboard anymore


#7

That sounds familiar. I know it gets tricky when you’re using Flexible SSL. So I suggest either:

  1. Get rid of those HTTPS references I mentioned, but make sure Cloudflare’s Crypto is set for Flexible and “Always Use HTTPS” is enabled as well as “Automatic HTTPS Rewrites” enabled at the bottom of that screen.

  2. Set up SSL where your site is hosted so you can use SSL Full, and keep all references to HTTPS on your site.


#8

So I went with choice one: It seems to have restored order to my website, but I cannot 100% tell, because I enabled construction mode earlier in this process, and I still can’t get to my wp-admin page.

As for option 2: I’m trying to avoid going through my host up with my host because it requires me to pay an obnoxious yearly fee to enable SSL. Here are the plans:

When I asked them about the 3rd party installation, that’s when I was told I need an RSA key.


#9

Cloudflare has a Free one you can use for that 3rd party installation. It only works when you’re using Cloudflare set to Full (or Strict), so you’ll have to remove it if you ever stop using Cloudflare:


#10

Pfffttt… IDK why I would ever stop using Cloudflare, it’s awesome! :grinning: Thank you very much for the help! I’m going to go with the third party installation and see if I can get that to work!


#11

I hope you don’t mind but I went ahead and made this its own topic.


#12

I don’t mind. Thanks again for the help!