SSL not working for Webmail

Greetings,
I have been using Cloudflare for my site along with the Full SSL for the free certificate. I run Godaddy hosting.

While I was configuring the MX for receiving email in Cloudflare, what I noticed in my Zone Editor at Cpanel is that it pointed destination towards “yoursite.com”(first) instead of “mail.yoursite.com”(later) and further exploring configuration options for email through Cpanel, it recommended to use the first instead of the later for secure SSL connection which I did.

Now when I try to add my same mail to the G-mail app client in my phone it rather uses the insecure connection and when I force it to use the secure port by changing configuration, it is unable to and shows an error. What am I doing wrong?
Help will be appreciated and thank you a lot!!

You need to use mail.example.com for MX and SMTP/IMAP/POP and it has to be set to :grey:.