SSL Not Working For Site

Hi there. I’ve just set up Cloudfare for my website, but attempting to reach it gives “Your connection is not secure” and similar warnings.

The dashboard claims my site is protected. I have swapped nameservers and set “Always use HTTPS servers”.

Website: https://www.beyondthebrawl.co.uk/

Any ideas?

Loads fine for me, can you share a screenshot?

1 Like

On Google Chrome:

Ah, got it, Check out this tip

Ideally, you need to get a certificate on the origin and make sure the site is secure and then add it to cloudflare. Troubleshoot the error CERT_AUTHORITY_INVALID with the above tip for the steps & options. Let us know how it’s going.

1 Like

Can you click that “Advanced” button and post a screenshot of the result? It should show you the cert that’s being rejected. My guess is that you’re bypassing Cloudflare due to some DNS setting you have.

What’s your SSL/TLS setting? It should be Full (Strict) as a server should have a proper certificate for your site, but I’m afraid that’s not the case with this domain.

1 Like

Here’s the rejected certificate:

I do have Full (Strict) on.
As for DNS stuff, I have been warned about this page. Is it alright?


Thanks for looking into this!

1 Like

It does like there are two issues:

  1. The certificate on your server does not match your domain name.

  2. For whatever reason, you’re going direct to the server. Either you have a local DNS issue, or you have a local hosts file with your server’s IP address. You’d need to get rid of that local hosts file entry.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.