Ssl not working for my subdomains

I have purchased ssl in cloudflare, it’s working for main domain, but not working for subdomain.
can anyone help me on it plz ,
I have raised customer support ticket for it

The cloudflare customer support is too worst, i am disappointing like anything.
tomorrow i have committed demo to customer, but the cloudflare don’t care about their customers.

Sorry that you’re having issues.

What’s the exact error and what do the domains look like?
Best would be to share the domains in question if you feel comfortable with it, so we can have a look.
(We can’t access your account data)

Most common issues are:

  • DNS propagation issues
  • Sub domain is not proxied (:grey: instead of :orange:)
  • Browser / DNS cache issues.
  • An attempt to use SSL on 4th level, like
1 Like

thank you for your reply bro,below is the error message

let’s see bro, if today can’t resolve planning to delete account from cloudflare, thought big with cloudflare
by god grace i know their support level with 5$. \

Honestly, i never seen such a lazy fu**ing service in my professional experience, i need to save the people who are suffering like me with cloudflare, will highlight it on social media.

If you have time help me bro, otherwise planning to network configuration on my dedicated server.

:wave: @joyacart,

What have you tried so far? A Google search turns up this as the first hit: Community Tip - Fixing Error 525: SSL handshake failed

Have you tried any of those steps? If so what was the result?


:wave: @joyacart,

It appears you have an issue on your origin server. Step 8 in the linked article would demonstrate that your origin server returns an error when Cloudflare isn’t involved as a proxy. You can also validate that with curl direct to your origin.



I have purchased another certificate to resolve my case, but i have disappointed lot from cloudflare.

Sorry to hear, but I can’t second that.
I always get fast and proper responses, even for my free sites. If you post the Ticket ID someone from the team can have a look what’s going wrong.

About the error:
Seems that your webserver was not properly configured to handle SSL traffic. That’s no issue of the certificate itself.

1 Like

Hi @joyacart. I see support was able to confirm the subdirectory is serving the proper certificate and noticed their suggestion to turn on universal ssl. After enabling Universal SSL, did you notice any other issues?

This topic was automatically closed after 30 days. New replies are no longer allowed.