SSL not working for Google Cloud Storage Static Website


#1

I have a static website on Google Cloud Storage. affordabledrivingschools.com

I have updated NS to reflect CloudFlare NS, two days ago, DNS lookup confirms they are active for my domain, as does Google Domains UI (this domain is registered with Google)

I have opted to use SSL on CloudFlare, the status after 24+ hours was still “pending”…

I tried using “Flexible” certificate option within the CloudFlare Crypto options…

Still no SSL.

Is there anything I am missing?

I suspect I need to disable the Google Cloud Storage Bucket SSL / TLS enforcement, but wanted to ask the community first before I cause more down time or errors.

Thanks, in advance

-Ryan


3+ DAYS SSL still showing as “Authorizing"!
#2

Where does it say “pending”? According to the docs, it would say “authorizing”. But here are some suggestions:


#3

I will look at that info you shared now too…thank you.
NOTE: I had originally just selected “FULL” SSL; that did not work for over 24 hours; so yesterday I decided to try FLEXIBLE… still no effect.


#4

Full/Flexible doesn’t matter when it does to certificate issuance. But Full is better and hopefully Google Cloud Storage has SSL enabled already.


#5

Yes, GCS is preconfigured with SSL.


#6

I tried updating CNAME to c.storage.googleapis.com.
Each time I try, website is unavailable.

Am I doing something wrong here? I’m new to CloudFlare, forgive me. :confused:


#7
  • I have a Google Cloud Static Website.
  • My Domain resides also in Google Domains.
  • I have changed Google Domain NS server to those for CloudFlare.
  • I have the host records configured in Cloudflare DNS as pictured (see attached).
  • I have selected to have SSL enabled (Free Account)

Am I missing something here?
I simply need to provide SSL for this domain, what’s missing?

My understanding is that I change CNAME at Google DNS to point to CloudFlare DNS. Done that.

Screenshot of my Cloudflare DNS
29%20PM

Screenshot of CloudFlare SSL STILL showing “Authorizing Certificate"
13%20PM


#8

This is a natural thing.


#9

LOL. What does that mean?