SSL not working for Google Cloud Storage Static Website

I have a static website on Google Cloud Storage.

I have updated NS to reflect Cloudflare NS, two days ago, DNS lookup confirms they are active for my domain, as does Google Domains UI (this domain is registered with Google)

I have opted to use SSL on Cloudflare, the status after 24+ hours was still “pending”…

I tried using “Flexible” certificate option within the Cloudflare Crypto options…

Still no SSL.

Is there anything I am missing?

I suspect I need to disable the Google Cloud Storage Bucket SSL / TLS enforcement, but wanted to ask the community first before I cause more down time or errors.

Thanks, in advance


1 Like

Where does it say “pending”? According to the docs, it would say “authorizing”. But here are some suggestions:

1 Like

I will look at that info you shared now too…thank you.
NOTE: I had originally just selected “FULL” SSL; that did not work for over 24 hours; so yesterday I decided to try FLEXIBLE… still no effect.

1 Like

Full/Flexible doesn’t matter when it does to certificate issuance. But Full is better and hopefully Google Cloud Storage has SSL enabled already.

1 Like

Yes, GCS is preconfigured with SSL.


I tried updating CNAME to
Each time I try, website is unavailable.

Am I doing something wrong here? I’m new to Cloudflare, forgive me. :confused:

1 Like
  • I have a Google Cloud Static Website.
  • My Domain resides also in Google Domains.
  • I have changed Google Domain NS server to those for Cloudflare.
  • I have the host records configured in Cloudflare DNS as pictured (see attached).
  • I have selected to have SSL enabled (Free Account)

Am I missing something here?
I simply need to provide SSL for this domain, what’s missing?

My understanding is that I change CNAME at Google DNS to point to Cloudflare DNS. Done that.

Screenshot of my Cloudflare DNS

Screenshot of Cloudflare SSL STILL showing “Authorizing Certificate"

1 Like

This is a natural thing.

1 Like

LOL. What does that mean?

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.