SSL not working for all URLs included

I successfully set up an SSL on an origin server. It seems to be working fine on the site and shows secure, but only when typing the full url or just www dot exemplaryva dot com

I prefer to have promos and other publications simply say exemplaryva dot com and I usually only type other urls with just the domain, so I expect potential clients would do the same.

But, when I do that for this site, it shows up not secure. However! It then changes the domain shown in the URL strip as the base domain once it engages the site.

Scratching my head. The base domain was included in the SSL certificate when generated. Any insight on what might be going wrong?

Thank you!

https://exemplaryva.com/ works fine for me however http://exemplaryva.com/ does not redirect to it

turn on “Always Use HTTPS” in SSL/TLS → Edge Certificates

this should make it always redirect to HTTPS, if the traffic is proxied, which it is

furthermore, this is more of a SEO thing, but you have https://exemplaryva.com/ and https://www.exemplaryva.com/ serving the same content without a redirect. You should consider choosing one as your primary and redirecting the other to it, i.e. redirect www to the apex domain, or vice versa. The canonical tag on your page implies you consider the apex domain to be canonical so you should probably redirect www to it.

Thank you for your help. I’ll make sure to consider these changes and to update the selection for Always using HTTPS. The other suggestions you made could be why things are snagging on load as well.

I appreciate you!

The page loading speed seems okay for me. You could try https://pagespeed.web.dev/ which might offer some suggestions for speeding it up.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.