Ssl not working/ always use Https not working

Hi, i wanted to to have a secure ssl for my wordpress website. I followed all the steps - changed nameserver , installed plugin and enabled “always use https” . So when i reload my site , the lock icon appears and then is replaced by ! (Not secure) sign.
Please help.

Not that this topic was not already discussed a millions times.

The most important question, do you have a certificate on your server in the first place? If not, there is no point in discussing anything else.

No i dont have it on the server. There is nothing much sensitive information to on the website. Its just the fact that i want to get rid of the ! sign.
If necessary , how can i get a cert. on the server ?

Of course, otherwise SSL won’t work.

If you say there is no sensitive information you can also disable HTTPS and have everything on HTTP. In that case you won’t need any certificate. Switch to “Off” for that.

Is there a way to get rid of the ! sign .

Yes, fix your server certificate or disable HTTPS.

so i disabled https and ssl encryption mode is flexible . But its still showing me a not secure sign.

You did not disable SSL, you need to set it to either “Off” or fix your server certificate. I wrote that quite a few times so far. What is not clear about that?

So i just set up a certificate on my cpanel of the server. Is that what fixing server cert means?

Precisely. You need a certificate on your server first. Then switch to “Full strict” and should you then still have any issues we can check them out in detail. But first you need a properl SSL connection.

just to make sure , is this what server cert is .

Yes, you need to take the public and the private key and configure that on your server.


Fair enough, that certificate seems to be in place now. Now switch to “Full strict” and the site should be secure.

i did it but still im seeing this.

That is this issue then

i think that is the problem. i checked my website and i found this. Is there any plugin that can do this.

You need to follow the advice mentioned in the article. If that doesn’t help it is beyond Cloudflare’s reach and you need to clarify any Wordpress related settings on a Wordpress forum I am afraid.