Ssl not work after re-enabling Universal SSL

SSL does not work after re-enabling Universal SSL.
Authentication Error Code 10000 keep appearing and “ERR_SSL_VERSION_OR_CIPHER_MISMATCH” is showing on my site.

I tried to disable the Universal SSL and re-enable it again after 10 mins but does not work.

then now “Error connecting to certificate service (Code: 1403)” is showing and the edge certificate status is “deleted”.

Hi @indeplaceonline, your ssl setting is Full (Strict) meaning you need a valid certificate on your origin server for end-to-end (visitor <-> origin server) encryption.

The error 10000 is occurring on your dash (mine too), but it’s not what’s affecting the certificate.

Here is a step by step #Tutorials that will assist in ssl setup, Step 2: Setting up SSL with Cloudflare

Here is some back ground on the error “ERR_SSL_VERSION_OR_CIPHER_MISMATCH" in Google Chrome. The error prevents access to the site because it detects an issue with creating a valid connection to your site. This may be a temporary issue, and should resolve itself within 24 hours. If not, grey-cloud/deactivate Cloudflare so that the website uses the origin’s SSL certificate, see How do I temporarily deactivate Cloudflare? Activate Cloudflare again in 24 hours and try to access your website to see if the SSL certificate has been successfully deployed.

Other successful troubleshooting suggestions and more details about the error can be found in this Community Tip. Let us know if you continue to see issues after trying these tips, we’re happy to help further.