SSL not showing up


#1

I have three wordpress sites. Low traffic non commercial.
I signed them up with Cloudflare and got a congratulations they are now active email and the following message:
“These domains are activated on your account and you can start configuring the performance and security features you like to use from your dashboard”
But nothing has changed. There is no SSl cert showing up.
My question is which dashboard and what features?
Any assistance will be appreciated
Thank you
quietmind.ca is one of the sites
Barry
.


#2

The certificate is there (sorry, screen shot is german :wink: ))

image

The green lock is not showing up because there is insecure content (mixed content)
loaded. Ppictures for example that are not served via HTTPS

Login to Cloudlfare -> Crypto -> scroll down to “Automatic HTTPS Rewrites”

But I recommend to automatically redirect all HTTP traffic to HTTPS directly within your server. configuration.


#3

Things are totally screwed up. I am way out of my depth.
I can’t get in the back end of my sites one of which doesn’t load.
I am trying not to panic.
If I reverse what I did at my host, will things go back to where they were?
Thanks
I did what you suggested by the way.


#4

@MarkMeyer is right about mixed content, however, do take note that Cloudflare only rewrites resources that supports https (no point in rewriting a resource when they do not support https, it will just make the resource unavailable). They achieve this is by using Chrome’s HSTS preload list as well as HTTPS Everywhere ruleset.

I am able to access quietmind.ca currently, and I am prompted to fill in a password. Not sure what you meant by “I can’t get in the back end of my sites one of which doesn’t load.”.


#5

Don’t panic. There’s nothing lost as it’s just a connection issue. Reverting those changes will make you pages available again.

What did you change exactly and where?

@edricteo
I assumed that the server already does support SSL. I should think a bit more basic :frowning:


#6

Thank you for the response.
Yes Quietmind.ca and mhansen.ca show up wowfancythat.com does not load.
I can’t log in to Wordpress dashboard with quietmind or wowfancythat.
I have no idea what to do about any of it except try to reverse the whole process.
If i revert the name server back to where it was do you think it will fix fit?
Thank you.


#7

The WordPress issue could be related to https as well. Do you get any error message? Like “too many redirects” for example.

Disabling CloudFlare should be enough to check if there are issues with your server or configuration. Just set the according records back to :grey: and wait for the TTL to expire. Usually it is set to " Automatic" which is 300 seconds, except you’ve set it to a higher value.
After that you will be connected directly to the origin server. If your issues are related to your CloudFlare settings everything should be fine then.


#8

Thank you.
I changed the name server and the dns or ns records to go from Netfirms to Cloudfare as instructed.
The dns records were named the same as the Name Server. Should I not have done that?
I also installed a plugin called Really Simple SSL I was following the instructions from here:
https://www.youtube.com/watch?v=7zVCn-9IYws&t=777s which is where I found out about Cloudflare.
Thanks for your assistance.


#9

Yes I do get that message or have seen it I think.
Where do I set the according records, I don’t know what the little grey cloud means.
I am sorry , I really am out of my depth, I should not have started this, I thought it would be simpler.
I should explain I have one hosting account at Netfirms and the three domains hooked up to it.
Thank you


#10

Login to your CloudFlare account
-> select the domain you want to edit
-> go to “DNS”
There you’ll find all DNS records that are set for your domain and the :orange: I mean.

You can activate (:orange:) or deactivate (:grey:) CloudFlare there by clicking on the cloud symbol.

The WordPress Plug-in should be fine. I’d have to search the forums for alternatives as this is a common issue. I simply can’t keep the plug-in in mind that’s recommend so often here. :joy: I am mobile at the moment and it’s a bit difficult. I’ll do when I am at home and edit this post.

EDIT
Thanks to @andy for liking another post. I was able to find a thread via his profile :grinning:

Please read this @wowfancythat

https://community.cloudflare.com/t/cant-access-wordpress-after-activating-cloudflare/

This should help you to get rid of this redirect thing


#11

Thank you so much for your response.


#12

Hi there,

Thanks @MarkMeyer for the mention.

@wowfancythat - WHOIS information indicates you’re not using Cloudflare nameservers currently, so your traffic is not going through Cloudflare at the moment. You can also check your nameservers here.

I see that there is a redirect in place on your origin server redirecting all requests to https://wowfancythat.com but the redirect results in an Invalid certificate chain error due the common name on the certificate belonging to another domain. This is something you would need to work with your hosting provider on addressing. You may provide them with this output if they need it:

$ curl -svo /dev/null https://wowfancythat.com/
*   Trying [REDACTED]...
* Connected to wowfancythat.com (REDACTED) port 443 (#0)
* found 148 certificates in /etc/ssl/certs/ca-certificates.crt
* found 592 certificates in /etc/ssl/certs
* ALPN, offering http/1.1
* SSL connection using TLS1.2 / ECDHE_RSA_AES_128_GCM_SHA256
*        server certificate verification OK
*        server certificate status verification SKIPPED
* SSL: certificate subject name (*.netfirms.com) does not match target host name 'wowfancythat.com'
* Closing connection 0

Ultimately it is up to you to decide if you want an SSL certificate from your hosting provider on your server or not. Our SSL options provide the flexibility for various scenarios.

I hope this helps.


#13

I followed the link you provided (Whatsmydns.net) to check the Name Server for wowfancythat.com, there was a long list, all correctly said Netfirms except one and it said:
Kaliningrad, Russia
VimpelCom
melissa.ns.cloudflare.com
rodney.ns.cloudflare.com
Is this the problem? if so, could you tell me how to fix it. I don’t know what else to do.
I checked with my hosting provider (Netfirms), they said everything at there end was functioning correctly.
Thank you for your assistance.
Once this is fixed is there a place for a blow by blow description for doing this correctly?
Thanks Agian


#14

CloudFlare’s out. The currently the Nameservers from Netfirms are answering the DNS requests.

All traffic is being redirected to HTTPS, which is usually good :+1:

But: currently there’s a wild card certificate configured which has been issued for *.netfirms.com which is not good because browsers will show a privacy warning.

You will have to talk to your provider how you can obtain a free certificate which will be issued for your domain(s) or how to create a self-signed certificate. Most providers support Let’s Encrypt which is free.

Note:
If you decide to use a self-signed certificate you will get a warning as well, as long as your page isn’t active on CloudFlare. After that it will magically disappear. :wink: Users will see a CloudFlare certificate and the traffic between CloudFlare and you server will be encrypted with your self-signed cert.

I assume you’re still having problems to login?
To sort out your WordPress issue you’ll need to deactivate the redirection of HTTP traffic to HTTPS through your hosting panel (CPanel, Plesk or whatever it is) or directly in the server configuration

After that you should be able to login again via HTTP.


#15

This topic was automatically closed after 14 days. New replies are no longer allowed.