SSL not showing on my site

Hello
I have add cloudflare on my website but ssl certification notshowing on my website codegyan. so that its show privacy error.

Please help me

The screenshot shows the certificate has an invalid date, this is likely the SSL certificate on your origin. Make sure that’s updated.

Then check your Cloudflare SSL/TLS setting is set to “Full (strict)” here…
https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls

Your site appears to be proxied so maybe you have made changes since posting or the DNS changes haven’t propagated through your local DNS resolver yet…
https://cf.sjr.org.uk/tools/check?d508943ad16a407e8b465aaaec10ee15#connection-server-https

1 Like

Hello
Thank you for replaying i have using ezoic. can you please help me to fix this ssl issue ?

Your site appears to be working correctly for me. If you still have issues, then check for any issues local to you (DNS resolver, ISP block/filtering, etc).

Lets me know can you see ssl lock :closed_lock_with_key: on my website by your browser.

You can see it’s working here…
https://cf.sjr.org.uk/tools/check?acfa4dd0e6a54badb1f21e88128b0574#connection-server-http

…and here…

1 Like

On Safari browser homepage showing secure but subdomain not

check “developer.codegyan.in” or “tools.codegyan.in”.

and in chrome browser home page and subdomain show not secure.

see on safari subdomain not working

All appear to be ok to me and are proxied through Cloudflare. You need to check locally if you have hard coded your origin IP address into your resolver or hosts file.
https://cf.sjr.org.uk/tools/check?d647b9ff6a3c4be8b275707b7208297d#connection-server-https
https://cf.sjr.org.uk/tools/check?f23666a5e1ef4bbd82cb07cc9dca0738#connection-server-https

Note that if you are using Cloudflare to front SSL for your website, that’s not recommended. You should set your SSL/TLS mode to “Full (strict)” and install an SSL certificate on your origin server (either a Cloudflare origin certificate, or a trusted CA like LetsEncrypt) otherwise your users’ traffic is not secured end-to-end and the padlock is deceiving them.

1 Like

SSL problem solver but now getting this problem. i used ezoic so i contact them then say allowlist there ip address.

Thank You !

A 520 error means the origin server is returning an error to Cloudflare. You should pause Cloudflare, or set the DNS record to “DNS only”, find the error, fix it, then you can re-enable Cloudflare.