SSL not active even after 3 days. It shows Authorizing Certificate


#1

Hello,

SSL is showing Authorizing Certificate even after 3 days of signing up

Ticket no is 1631370. Raised it 3 days back

Please help me to get SSL activated on my site.

Thanks


#2

Hi @lifeupgrademastery, sorry about the delay. On the crypto tab, can you disable universal ssl, wait 10 minutes and then re-enable it? I’ve made some notes on your ticket and a link to this conversation.

Edit - @lifeupgrademastery, the toggle seemed to work and I can see ssl is active, the certificate is in place, and the page loads securely.


#3

Hello,

Thanks for the reply. But SSL is not working. I am getting secure connection failed in browser and here is the whynopadlock report- https://www.whynopadlock.com/results/5bdcc2e5-5f33-439e-beee-5ed5fe14499b


#4

#5

Hi @lifeupgrademastery, really odd but I no longer see the cert, either.

The tip from @Withheld will help with the cipher mismatch issue and this one will help address the mixed content issues, Community Tip - Fixing mixed content errors.

But, we need to get that cert authorized first. On the crypto tab at the bottom of the page, can you turn off universal ssl, wait 10 - 20 minutes and then turn it back on? Do not adjust the off, flexible, full, full (strict) toggles at the top of the page just yet.


#6

Hello,

Thanks for reply.

As you said, I disabled Universal SSL and enabled it after 20 minutes. SSL is still not showing.

Is there a way to use SSL provided by my hosting provider along with Cloudflare free plan ?

Thanks


#7

Hi @lifeupgrademastery, sorry, not on the free plan.

But, on the crypto tab, please enable always use https and automatic https rewrites. Let us know how it works.

Edit: I hope like this:


#8

Hello,

Thanks you so much for helping me with it. Its working now. After enabling https rewrites also it was showing some mixed content so I used a plugin to fix it and now SSL is working properly.

Also can you tell which type of SSL is best used, flexible, full or strict ?

Thanks for your help. :smile:


#9

Thanks for stopping by! You should set to flexible for now. You can add a a free self-signed cert on your origin and then set to full. You can do that from the crypto tab. That way you have a certificate between your visitor and cloudflare and the self-signed cert between cloudflare and your origin.


#10

What positive or negative impart my website will have on using Full SSL ?


#11

Full strict is great, if your origin has the correct certificate, otherwise you’ll get an error. Here’s the rundown of the options and what they mean, https://support.cloudflare.com/hc/en-us/articles/200170416-What-do-the-SSL-options-mean-. A free self-signed you generate from your dash is the path of least resistance.


#12

In my hosting I have Lets Encrypt installed. Can I use Full SSL with it or I need to manually add SSL in hosting before using FULL ?

Here is the screenshot- https://i.imgur.com/Pyekpqn.png

Thanks


#13

If you have a Let’s Encrypt cert on your server then yes, you can use full.


closed #14

This topic was automatically closed after 31 days. New replies are no longer allowed.