SSL Negotiation failed

Hello! I am a bit concered about an issue which I am facing. I’ve found a similar thread here but without an answer. Whenever I whois my website I see in the website title 500 SSL negotiation failed. In the response code: 500. My website is perfectly accessable but this is affecting the SEO of the website as when I try to use search console and inspect a URL it is saying that the url is not on google. I’ve checked with the hosting company and provided them with a HAR file but they’ve told me that the issue should be from CloudFlare as the SSL certificate is issued by them. Anyone with an idea how to proceed as I’ve tried contacting CloudFlare support team still without reponse. Just an automated message from the CloudFlare BOT with this:

We have analysed the analytics from your zone, this information is included below. Please note that this is a sample of the analytics data for your zone, for more detailed information please see the Analytics tab on the Cloudflare Dashboard.

  • 200: 300
  • 301: 65
  • 499: 53
  • 304: 13
  • 403: 13
  • 404: 12
  • 523: 4
  • 405: 1

I see the ticket from last week, the auto reply, and your response over the weekend. That reply reopened the ticket and it’s in queue.

I’ve added myself to it to track progress, although I cannot reproduce the error. If you have TLS 1.3 enabled on the TLS/SSL app of the Cloudflare dashboard, Edge Certificates tab, can you disable and try again? Can you attach a screen shot of the error you’re seeing?

Hello cloonan, thank you for your reply

I had the TLS 1.3 enabled and just disabled it, tried to whois the website and still I receive the same “error”. I am attaching two images (combined into one): one from rescan and one from whois.domaintools.com. I am not sure what [Server IP] RKN blacklisted is. Shouldn’t this be the CloudFlare IP address?

This topic was automatically closed after 30 days. New replies are no longer allowed.