Ssl_mismatch

dash-crypto
#1

I’m receiving a “ssl_mismatch” error message from android phone (note 8) when on cellular connection, but not when on wifi. I don’t receive the error on PC, Mac, or iPhone. I’ve restarted the phone, cleared the cache in the browser, and wiped the cache partition, still no luck. Any thoughts?

#2

Try http://example.com/cdn-cgi/trace (for your domain) on your phone and see if you’re actually going through Cloudflare.

If you post the domain name, we can take a closer look.

#3

Domain name is https://bradwenskoskiphotography.com

#4

Do you get same error for other https addresses? Are you redirected to a Captive Portal?

#5

No, only my site as far as I can tell. I even did a factory reset of the phone because that was the last step in troubleshooting that I found. Still no luck.

#6

What browsers you have tried on that phone?

#7

No captive portal. Attached is a screenshot when clicking the link from Facebook.

And from directly navigating to the site from chrome

#8

This is a similar situation which fixed by disabling/enablig SSL in Crypto section of CF panel.