SSL mismatch error


#1

Hi, I need a help here, after setup my domain with Cloudfare SSL, I face this issue - “The client and server don’t support a common SSL protocol version or cipher suite.” Unsupported protocol
What is the way to solve this issue ?
Thanks for any help.


81053 Error when I try to integrate Cloudflare with Kajabi
#2

You should update your server config to include supported cipher suites. It’s also great idea to update server software if it is out of date. :slight_smile:


#3

If your certificate on the origin server needs to be upgraded you can install an origin cert from Cloudflare on the server if you’re managing it (Origin Server Certificate on the crypto tab). If you aren’t managing the machine running your site you will probably want to reach out to you hosting provider. They may be able to install a free cert (Let’s Encrypt Cert typically).


#4

If security isn’t of paramount importance and you want to minimise messing around, you could also try setting your SSL level to ‘flexible’ such that traffic between Cloudflare and your host is plain old HTTP, not HTTPS. Obviously clients will still get HTTPS connections to Cloudflare. I wouldn’t advise it for anything serious but for a blog or other basic site, and if you don’t have the access or inclination to fix the SSL ciphers on your host, it should resolve your issue.


#5

I’ve seen this issue with ECC Certs, switching to RSA solved the issue.


#6

I have this message and am wondering how to fix it. I am using Flexible and the site is an Azure web app.